The best kittens, technology, and video games blog in the world.

Thursday, August 18, 2016

Map mode for Hearts of Iron 4 resistance and suppression system

If HoI4 developers insist on keeping the current resistance and suppression system, and I think they shouldn't, the bare minimum they need to do is making its map mode functional.

Unfortunately there's no way to make them do so, and no way to mod map modes in-game (one of the biggest gaps in modability - like where are truce map modes?). So as the next best thing I grabbed my old map generation scripts (which I originally used for generating timelapse gifs for my EU4 campaigns) and adapted them to display suppression information for HOI4.

Here's alt-tab map mode for that, the way it ought to work.

Colors and numbers indicate how many 1cav divisions you need to suppress states, with correctly applied rounding etc. All colors for 15+ cavs are the same, as it felt unnecessary to have whole scale for just a handful of provinces.

See my previous post for explanations of why 1cav is best strategy and math behind it all.

Gentlest:


Gentle (default):

Harsh:

Harshest:

This is pretty much what I'd like to see in game when you select resistance map mode. Not forcing math on tooltip - just show by colors and numbers how many units are needed to keep a state in good order.

EDIT: Updated for 1.5.0. Differences between versions are minimal.

5 comments:

Anonymous said...

I know you wrote this years ago and I still think it's the most useful HOI4 thing ever made as it's intuitive for dumb asses like me; any chance you could update for the new map which came out?

taw said...

Anonymous: I updated the map. From 1.1 to 1.5 all differences are slight border tweaks to existing provinces (not affecting where to place units), new 1vp in Namibia, and a few slightly bigger Chinese provinces tweaks.

It's close enough you could use this map for different version and probably wouldn't notice.

Charles Cone said...

I can't zoom in the maps anymore. Everything is too tiny to see.

taw said...

Well, it seems that blogger decided to ignore "original size" settings.

It should be working now.

Charles Cone said...

Thank you for the quick response!